Windows

Overview

There are two different Tappy SDKs available for the Windows platform, both written in C#. The TCMP SDK supports both TappyBLE and the latest versions of the TappyUSB, while the Classic SDK only supports the legacy TappyUSB devices that shipped prior to July 2016. A .NET version of 4.5.2 or greater is required to use either SDK. Additionally, the computer using the Tappy will have to have FTDI virtual COM port drivers installed. Many machines will already have the necessary drivers, but, if not, they can be downloaded from FTDI.

TCMP SDK

The TCMP SDK natively supports TCMP TappyUSB devices without any special additional hardware. However, due to the spotty nature of native BLE support on the platform, interfacing to TappyBLE devices requires the use of a Bluegiga BLED112 BLE dongle. When used to connect to a TappyBLE device, the SDK will configure the Bluegiga dongle at runtime, so no special version is needed. For convenience, you can request a dongle to be included with your TappyBLE order. For additional information, please see the SDK repository on GitHub.

Get source on GitHub

TappyUSB Classic SDK

The TappyUSB Classic SDK only supports legacy TappyUSB devices using the deprecated Classic communication protocol. For further information, please see the SDK repository on GitHub.

Get source on GitHub